eComStation 2.0 RC4 WhatsNew

순수백수 0 32,141 2007.12.27 11:38
==== WHATSNEW for eComStation 2.0 RC4 ====

-=# The Christmas 2007 release #=-

New Features:

* Network reconfiguration now functions properly
* Detection of wired vs wireless NICs will be in proper order
* Added tool to configure a not-connected wired NIC interface (llaecs)
* Disk resizer has progress bar for improved usability
* New bootlogo and desktopbackground, reflecting "RC4" status

Updated Applications:

* Updated GenMac to "Release Version 2.20 RC1"
* Updated XWLAN utility to version 3.10 RC1
* Updated ACPI to version 3.05
* Updated both Firefox and Thunderbird to version
* Updated RSJ CD writer to 6.02
* Updated UniAud audiodriver to 1.1.4RC4 release
* Updated UnixLike utilities to support wildcard notation
* Updated tar (to 1.18), gzip (to 1.3.6) and bzip2 (to 1.0.4)
* Updated DOS kernel to 14.103
* Updated Time zone update for Java 1.4.2 to 2007H
* Updated MPTS Wrap to version 0908

Fixes since the previous release:

* 1686: [installer phase 2] Problem with OBJECT ID of mouse object
* 1796: [installer phase 2] GenMac needs to be installed completely on HD
* 1190: [other] APM Installation: config.sys missing: SET ENH_SUSPEND=2
* 1626: [booting of CD] XUL disc resizer
* 1633: [installer phase 1] Broadcom NeteXtreme Gigabit NIC not detected
* 1704: [other] If both GenMAC wirless interface and second inteface have
        TCPBuei enabled, Peer will not start
* 1625: [installer phase 2] eCS 2.0 rc2 error code 85 when USB CD-ROM
        support is requested
* 1800: [other] Apply ABIOS patch to OS2LDR
* 1700: [installer phase 3] ecs 2.0 it_it rc3: finalization wizard writes
        USER variable uppercase
* 1583: [other] Included versions of archiving utilities like tar, gzip,
        bzip2 are not the latest versions
* 1572: [installer phase 1] SEINST install failed
* 1711: [installer phase 1] System crashes without /!BIOS
* 1752: [installer phase 1] Trap E in OS2KRNL on starting install
* 1672: [other] Shutdown menu (estyler) does nothing if no selection is made
* 1707: [other] selecting panorama causes finish.cmd to run makewps.cmd
        from snap
* 1685: [other] Network reconf no longer works
* 1795: [other] Selective installer for networking destroys system
* 1738: [other] After successful installation, 'Selective Install for
        Networking' causes a loop in phase 2
* 1607: [installer phase 1] Broadcom 10/100 network adapter not present in
        macs listing.
* 1198: [other] Do not run CFGSORT on (network) reconfiguration
* 1732: [other] NIC not detected on HP compaq NC6320
* 1659: [booting of CD] Experimential features
* 1564: [other] (eCS 2.0 RC1) WPSEXTS missing
* 1781: [other] is down level.
* 1669: [other] Amouse needs /SMP switch in SMP mode
* 1712: [installer phase 2] LAN not working, IBMLVL.INI not readable by
* 1789: [other] JUNE.LNG misses texts and one sentence needs modification.
* 1504: [other] On this system V2.0B4 using GenMac for Broadcom NetXtreme
        NIC failed to install ANY copy of mptn.msg
* 1631: [other] mptn.msg missing
* 1580: [other] changing video drivers results in an unstartable system
* 1720: [other] Missing menuitems: Create another.., Create program object
* 1746: [other] Need to update the Samba client code in the EVFS package
* 1777: [installer phase 1] LVM fingerprint check text needs fixing
* 1722: [installer phase 2] Trap 000e ThinkPad R61
* 1724: [installer phase 1] Due to HW detection order Wireless is put on lan0
* 1641: [installer phase 1] Dual Core CPU installs W4 Kernel with "/SMP"
        option in ACPI.PSD. Result: stop at bootlogo.
* 1750: [other] FAT 32 IFS
* 1779: [other] WinOS2 apps lost during migration.
* 1688: [booting of CD] Install eCS 2.0 RC 3 in Virtual PC
* 1693: [installer phase 2] eCS 2.0 rc3 hangs loading drivers at phase2
* 1708: [installer phase 2] System hangs
* 1705: [installer phase 2] /APIC not filtered from ACPI.PSD line in phase2
* 1740: [other] MPTS does not work
* 1706: [other] x:\ibmcom\macs contains too many NIF files, causing MPTS to
* 1695: [other] MPTS crashes after easy install eCS 2.0 rc3
* 1733: [other] ACPI Wizard parameter parsing logic
* 1767: [other] Selective install *still* has OS/2 Warp 4 background and
* 1776: [other] UCLIP locations
* 1775: [other] en_us\ecs\install\ contains a duplicate of itself
* 1758: [installer phase 1] Configure Network page references "Netware"
        instead of "NetWare" and needs additional fixes
* 1759: [installer phase 1] Network types text needs cleaning and consistency
* 1765: [installer phase 2] Disk inactivity warning text
* 1754: [installer phase 1] Language on resistration info page should be
* 1757: [installer phase 1] Registration screen text needs more polish
* 1751: [other] Unix-like commands in ecs\klibc (coreutils)
* 1761: [installer phase 1] When adding IPX, it is only available for binding
        to the first NIC
* 1742: [other] Couldn't configure MPTS .
* 1684: [other] Scheme Palete doesn't contain a setting for current colors
* 1703: [other] Default locale is still not correctly set during install.
* 1718: [installer phase 2] hang loading BASEDEVs

Updated / added drivers:

* Updated ACPI to revision 3.05
* Updated APM to revision 1.20
* Updated UniAud audiodriver to 1.1.4RC4 release
* Updated JFS code to match eCS Bootable JFS 1.0.7
   The updates for the latest IBM JFS support (14.105) have been merged
   into this release.  It is valid for both HPFS and JFS systems.
* applied IBM APAR PJ31116/PJ31056 Comet Cursor/Suspend (@@fixes 1781)
* samba plugin code at level 3.0.26 @@fixes 1746

New features of previous release:

* Updated Nvidia NDIS (nveth) driver to version 0.0.4
* Updated GenMac 2.1.110 (experimental) to support these additional chipsets:
   3Com 3C90xC   PCI [10B7:9200]
   Rtl 8168 GigaBit [10EC:8168]
   Rtl 8169 GigaBit [10EC:8169]
   Broadcom 10/100 [14E4:170C]
   Broadcom 10/100 [14E4:4100]
   Broadcom 10/100 [14E4:4401]
   Intel 10/100 [8086:1229]
   3Com 3C90xC   PCI [10B7:9201]
   nForce 5 10/100/1000 [10DE:0373]
   Marvell Yukon 88E8052 [11AB:4360]
   Marvell Yukon 88E8050 [11AB:4361]
   Marvell Yukon 88E8055 [11AB:4363]
   Marvell Yukon 88E8056 [11AB:4364]
   Atheros Wlan AR5005g [168C:001A]
   Atheros Wlan CARDBUS [168C:001B]
   Attansic Gigabit [1969:1048]
   Intel 10/100/1000MM [8086:1049]
   Intel 10/100/1000MM [8086:104B]
   Intel 10/100/1000PL [8086:109A]
   Intel 10/100/1000PL [8086:10B9]
   Intel 3945 a/b/g [8086:4227]
   Intel 4965 a/g/n [8086:4229]
   Intel 4965 a/g/n [8086:4230]
   Rtl 8167 GigaBit [10EC:8167]
* Panorama VESA videodriver can be selected for installation
* Added AMouse mousedriver as default in the installation (fixes 1561)
* Added cleanup of 'empty' network folders that remain on the desktop
  when no actual network was installed.
* Created wrapper for PCI.EXE to add serial port support detection using
  DMI. (fixes 1253)
* Improved NIC and soundcard detection by using wrapper for PCI.EXE
* Added detection of 22 new NIC chipsets (supporting total of 304
  additional NICs) by GenMac 2.1.110 (experimental)
* Updated DSSaver to level (eCS internal buildnumber)
* Updated Firewall to 2007/09/03 version
* Updated USBDock to 2007/09/08 release
* Updated Lucide to 1.20
* Updated eWPS to 1.08 (it was supposed to be in earlier verions, but
* Updated DejaVu fonts to version 2.20 (sept. 2007) and added some
  missing fonts from the set. (fixes 1423)
* Netware client can be installed from CD1
* Added 27 NIC devices supported by the Nveth driver
* Improved artwork in installer screens
* Updated 4OS2 to build 3.04g (now build dynamically)
* Updated Firefox to version (with WPS integration)
* Updated Thunderbird to version (with WPS integration)
* Updated Dani IDE drivers from 1.7.10 to 1.8.1a
* Updated kLibc to latest version 0.6.3
* Updated UniClip to version 0.3.0
* Added ACPI Wizard that will detect system features and can be used to
  install ACPI and kernel options
* Updated DANI tools to 1.8.1 level
* Updated DANIS506.DOC to 1.8.1
* added ACPI package 3.01, can be manually selected or disabled in preboot menu
* Updated ACPI and APM support to 16/08/2007 version
* added Nveth driver to support nvidia (nforce) nics
* Updated Realtek 8139 driver to version 2005.12.05 which functions properly
  with ACPI
* Updated UniAud audiodriver to 1.1.4RC3 release
* Added TZ update for Java 2 SDK, Standard Edition - US DST timezone tool
* Split up netlabs (kLIBC) and innotek (Odin Runtime) libraries, are now
  installed with WarpIn
* Added support for the eComStation Installation Framework. Will always be
  installed. (XULrunner)
* Added logic to load TESTCFG2.SYS when ACPI is selected, prevents hangs
  on certain configurations
* Added english helpfile to accomodate checkdisk help button
* Updated USBDock to 20070504 release
* Updated WarpIn to version 1.0.15
* New versions of UPDTBMGR, MINILVM
* Updated ZIP to 2.32
* Replaced outdated ArcView 1.2 helpfile with the one of ArcView 2.0
* Updated eWorkPlace to 1.0.8
* Updated UniClip 0.2.2
* Updated Cairo to 1.2.4 and DSSaver to 1.7.5
* Updated firewall utility to version 1.2.4
* Updated NewView to 2.19
* Updated NewView en_us helpfile to 2.19
* Added 47 NIC devices to the hw detect engine, like nForce and Broadcom
  (mainly GenMac)
* UDF 2.16
* IBM APAR PJ30964 (UDF.IFS update)
* IBM1S506.ADD 10.161 (was 10.152)
* Intel SpeedStep(R) (APM) 10.163 (was 10.156)
* IBM Single Mouse driver 10.163 (was 10.152)
* KBDBASE.SYS to 10.070 (was 10.056)
* Updated IBM1S506.ADD to 10.161
* Updated OS2CDROM.DMD to 10.163
* Lucide document viewer (Lucide GA release)
* Added LxLite 1.3.3 to the distribution since resmgr uses it
* added bzip2 to \ecs\bin
* Security/2 added (optional from 'experimental features' in advanced
* Added 4OS/2 to Additional Software
* Added 4OS/2 prompt shadows to Command Prompts folders
* Added Genmac 2.00 with support for 34 NIC chipsets, including many
* Added Wireless LAN monitor 3.00, will be installed when appropriate
  hardware is detected or selected.
* Added Faxworks to CD1, it was on CD2 previously
* Added Psi/2 Instant messaging application
* Added Samba Client for eComStation. Right now without configuration GUI
* Added OpenSSH Client for eComStation.
* Added preinstall harddisk integrity check, can be skipped now from preboot
* Updated TZ settings for locale page to conform to new rules. More info at:
* Added USBDock as a replacement of the USB resource manager
* Added UniClip 0.2.1 to base installation, required by 2.0.4
* eClock is no longer an install option
* Added kLIBC coreutils
* All libc versions and utils are in WPI packages now
* Added MyIP by Alex Taylor to Baseutil
* Added files to support reversing SMP installation (used by "Post
  Installation Tasks" wizard)
* modified desktop scheme
* Scitech SNAP to 3.1.8
* Update realtek 1 gigabit driver
* Added Broadcom 1 gigabit driver
* Updated Uniaud to build RC2
  - Latest code for sblive cards
  - HDA works for DART (still buggy)
  - APM fixes
* Genmac adds support for the following NIC chipsets:
   3Com/SKNet Gigabit [10B7:1700]
   3Com/SKNet Gigabit [1148:4320]
   3Com/SKNet Gigabit [11AB:4320]
   3Com/SKNet Gigabit [11AB:4362]
   ASUS Wlan RT2400 [1814:0101]
   Atheros Wlan [168C:0012]
   Atheros Wlan [168C:0013]
   Atheros Wlan [168C:1014]
   Broadcom A/B/G [14E4:4324]
   Broadcom B/G [14E4:4318]
   Broadcom B/G [14E4:4320]
   Broadcom Gigabit [14E4:1654]
   Broadcom Gigabit [14E4:165D]
   Broadcom Gigabit [14E4:1677]
   Broadcom Gigabit [14E4:167D]
   CISCO mPCI [14B9:A504]
   Dlink DWL-520+ [104C:8400]
   Dlink DWL-G520+ [104C:9066]
   GN-WI01GS RT61 [1814:0301]
   GN-WI01GS RT61 [1814:0302]
   GN-WI01GS RT61 [1814:0401]
   Intel 10/100/1000 [8086:101E]
   Intel 10/100/1000 [8086:1076]
   Intel 10/100/1000 [8086:109A]
   Intel 2100 Wlan [8086:1043]
   Intel 2200 Wlan [8086:4220]
   Intel 2915 a/b/g [8086:4223]
   Intel 2915 a/b/g [8086:4224]
   Intel 3945 a/b/g [8086:4222]
   Marvel 802.11 b/g [11AB:1FA6]
   Marvel 802.11 b/g [11AB:1FA7]
   Rtl 8180 Wlan [10EC:8180]
   nForce 2 10/100 [10DE:0066]
   nForce 3 10/100 [10DE:00D6]
   nForce 4 10/100/1000 [10DE:0057]

Fixes and updates of previous beta releases:

* Further improved hardware detection, on certain systems network cards
  were not detected, although supporting drivers are shipped
* Many fixes and improvements to the ACPI Wizard (bugfixes: 1638, 1669,
  1601, 1641, 1637, 1649, 1602, 1638)
* Added CPUID.EXE (built by Paul Smedley - Copyright 2003,2004,2005,2006
  by Todd Allen.  All Rights Reserved.) for better detection of SMP
  capabilities by ACPI Wizard.
* Re-enabled USB HID features in installer hardware page. In combination
  with updates to OS2CSM this partly fixes 1212, 1260, 1424.
* Updated WIC.EXE to same level as WarpIn in CID package, added warpin.tmf
  (fixes 1663)
* Multimedia deselection also deselects MultiMedia plugin pack for browser.
  (fixes 1657)
* Updated MPTS Wrapper - now really fixes 1645
* Updated DSSaver, it now will be enabled after installation. (fixes part of
* Updated USBDOCK to let it add the USBRESMG.SYS to the config.sys itself
* Updated list of USB IDs with version of 2007/10/02
* Prevent applying of resource updates to (A)E.EXE (fixes 1438)
* DSSaver: updated WPSSDesk.dll to show correct initial properties notebook
  size. (fixes 1623)
* DSSaver: added sscore.cmd to write an initial sccore.cfg so screensaver
  will work even when not configured at all (i.e. after clean install).
  (fixes 1604)
* Apply SNAP setting for Netware (fixes 1597)
* Updated installation of GenGradd (fixes 1605)
* Minstpm fixes in hardwaredetection, use of paths with spaces (fixes bugs
  1227, 1254, 1338, 1378, 1461)
* Faxworks installation now done by means of WPI package
* Added MPTS wrapper script, will fix the HELPERW issue (fixes bugs 1455
  and 1555)
* Changed default installation from INSTDRV to EMXDRV (fixes bug 1557)
* Added EMXDRV variable for EMX installation XCD (fixes bug 1557)
* Updated MPTS wrapper to function with 4OS2
* Fixed ecsshell.exe to function properly when called with new config.sys
  settings of CD boot
* Fixed ACPI Wizard to not duplicate TESTCFG2.SYS entries in config.sys
* Do not sort config.sys if Netware is installed, sorting causes trouble
* Removed obsolete scripts PREPDLG.CMD and DIALOG.CMD
* Resolved problem of double GENMW32 drivers in config.sys (MPTS installs
  it in Phase 2)
* Fixed Advanced button on SNAP page (fixes bug 1249, 1541)
* No SNAP folder is created (fixes bug 1249, 1541)
* Dialog enhancements are no longer applied when disabled (fixes bug 1585)
* Easy install path did not install Thunderbird (fixes bug 1589) and Flash 5
  plugin (fixes bug 1588)
* Easy install path installed non-existant Acrobat Reader 4 (fixes bug 1590)
* Fixed: GenGradd installation could fail in phase 1.
* Now installation on a multiple CD configuration should work (fixes bug
  1476, 1510)
* Updated PMMERGE.DLL and symbol files to 14.106 (APAR PJ31908)
* IBM APAR PJ31319 (SYS3184 in PMCTLS.DLL)
* IBM APAR PJ30811 (Trap in FTPD)
* IBM APAR PJ30821 (Error in TELNET)
* Updated syslevel.bdd to bdd fp3
* Fix modal problem of status window of PMFormat (in installer)
* Some applications (EPM amongst others) weren't installed in Beta 4
* 'Advanced' button in Screen properties notebook now works
* Opteron CPU now supported in SMP mode
* 4OS2 windows now open a new session, defaults to root of bootdrive
* Improved layout and wording of Preboot Disk Integrity check messages
* Fixed GenMac NIF parsing by installer, fixes the PROTOCOL.INI errors
* Applied Bootable JFS fix (20070104fix)
* various fixes to eStyler installation (especially shutdown options)
* Selecting VGA in preboot menu actually selects proper settings during
  further installation
* Fixed GENGRADD installation
* Changed behaviour of ACPI/APM to prevent failing suspend mode
* Changed Danish locale to non-EURO
* Split up Thunderbird & Firefox, no longer required to be installed together
* Disabled installation of USBRESMG.SYS by Tame
* Shuffled packages in the package selection page of the installer, in an
  attempt to make it a bit more logical. Also, tried to shorten the lists.
* Changed Daylight Savings to 'Daylight Saving'
* Updated MINSTPM to accept eCS 2.0 install CD
* Updated NETWORK.EXE to accept eCS 2.0 install CD
* Added 'set tmpdir' variable to config.sys
* Changed final SGUIDE to not show EscapeGL anymore and to change the
  default DHCP timeout to 0 sec.
* replaced DOSCALL1.DLL with patched version that will first look for
  messages in msgfile, then in embedded msg, instead of the (incorrect
  default) other way around
* applied PJ31116 - fixed WPCONFIG.DLL to accomodate comet cursor +
  suspend (official APAR from IBM, now bld 14.105)
* applied pj31068 - fix for more than 1024 printer in prdesc.lst
* Binary fix to MPG.DLL number 2 by Sebastiaan Wittmeier. Fixes chipmunk
  audio playback.
* Applied Yuri Proniakins patches to install ewps properly
* Added WarpIN components needed for creation of eWPS WarpIN package
* Fixed eWPS ACPI dependency
* removed 'illegal' schemes from eSchemes WPI package 1.27
* Java 142: Added missing path for the font registration (fixes bug 1165)
* Bugfixes to ECSGUI packages and ESTYLER.
* Wording improvements in installer.
* Minor adjustments to desktop layout.
* cleaned up reseller section and added link to eCSoft/2 in URL folder
* Changed VIRTUALADDRESSLIMIT to 1536 (seems a popular compromise value)
* Changed default DHCP timeout to 0.
* SSES.SYS now uses /q (quiet) parameter when installed.
* Changed some logfile names (FFOX, TBIRD, SSES) so they fit 8.3 characters.
* Removed 'MOZILLA' from default Thunderbird & Firefox path in installer GUI.
* Improved some more wordings in the English packages list and message file.
* TCPCFG fix for Java 1.4 (CFG2NATV) is now always installed.
* Various updates to eStyler so it actually works now (mostly).  The shutdown
  properties notebook is broken, though.
* Applied fixes in ECSGUI.CMD.
* Updated SigmaMD5 to version 1.53
* Updated 4OS2 to version 3.04b
* Updated Newview to v2.18.1
* Updated Tame/2 scanning application to 1.05 (to be selected in Bonus
* Upgraded Archive Viewer to v2.0
* Updated Minilvm to 2.20 with resize feature
* Updated resmgr to the version posted by Chuck McKinnis dd 20060614
* Updated Doodle's screensaver to 1.7, added SlideShow module
* Memdisk and OS2CSM to 20061030 build
* Updated firewall to latest available version in Generic Network Utilities
* Updated Java Runtime to 1.4.2_09
* Updated eWorkPlace to 1.0.7, enabled these features:
  - Extended sorting
  - xShutDown
  - SortOrder
  - FoldersFirst
  - eComStation Kernel object
  - improved traywidget icon


  • 현재 접속자 273 명
  • 오늘 방문자 1,233 명
  • 어제 방문자 1,467 명
  • 최대 방문자 11,402 명
  • 전체 방문자 2,574,052 명
  • 전체 게시물 3,093 개
  • 전체 댓글수 4,605 개
  • 전체 회원수 107 명

- 쇼핑몰 : Softbox
- 예전 문서 / Old docs
- FTP Server:
Facebook Twitter GooglePlus KakaoStory NaverBand